Ext-Rtr
NDFC - Verify

Verify your Ext-Rtr configuration.

Step 1 - Login to Ext-Rtr

Login to your Ext-Rtr switch using the copy command below and paste into your VSCode Terminal. When prompted, the password is cisco.123 .

If prompted to accept the RSA key fingerprint like below, type or copy yes then input the password above.

    The authenticity of host '10.3.3.10 (10.3.3.10)' can't be established.
    RSA key fingerprint is SHA256:xneE+2XnZozaXwC/FgeYMRKJ4UhZV4iZD6QCD1u7gi8.
    Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
    Warning: Permanently added '10.3.3.10' (RSA) to the list of known hosts.
    User Access Verification
    Password: 

Step 2 - Ext-Rtr: Show Run Interfaces


show run interface ethernet 1/1-3 ; show run interface loopback0

Output:

    !Command: show running-config interface Ethernet1/1-3
    !Running configuration last done at: Wed Feb  1 18:15:48 2023
    !Time: Wed Feb  1 18:26:28 2023
    
    version 9.3(10) Bios:version
    
    interface Ethernet1/1
    
    interface Ethernet1/2
    
    interface Ethernet1/3
      no switchport
      mtu 9216
      no shutdown
    
    interface Ethernet1/3.2
      mtu 9216
      encapsulation dot1q 2
      vrf member bluevrf
      ip address 10.31.0.1/30
      no shutdown
    
    
    !Command: show running-config interface loopback0
    !Running configuration last done at: Wed Feb  1 18:15:48 2023
    !Time: Wed Feb  1 18:26:28 2023
    
    version 9.3(10) Bios:version
    
    interface loopback0
      description Ping Test Loopback
      vrf member bluevrf
      ip address 172.16.1.1/32 tag 12345

Step 3 - Ext-Rtr: Verify BGP Running Config


show run bgp

Output:

    !Command: show running-config bgp
    !Running configuration last done at: Wed Feb  1 18:15:48 2023
    !Time: Wed Feb  1 18:27:25 2023
    
    version 9.3(10) Bios:version
    feature bgp
    
    router bgp 65333
      vrf bluevrf
        address-family ipv4 unicast
          network 172.16.1.1/32
        neighbor 10.31.0.2
          remote-as 65111
          address-family ipv4 unicast
            send-community
            send-community extended

Step 4 - Ext-Rtr: BGP EVPN Neighbors


show bgp ipv4 unicast summary vrf bluevrf

Output:

    BGP summary information for VRF bluevrf, address family IPv4 Unicast
    BGP router identifier 172.16.1.1, local AS number 65333
    BGP table version is 7, IPv4 Unicast config peers 1, capable peers 1
    3 network entries and 3 paths using 732 bytes of memory
    BGP attribute entries [2/344], BGP AS path entries [1/6]
    BGP community entries [0/0], BGP clusterlist entries [0/0]
    
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    10.31.0.2       4 65111      18      17        7    0    0 00:11:42 2

Step 5 - Ext-Rtr: BlueVRF Route Table


show ip route vrf bluevrf

Output:

    IP Route Table for VRF "bluevrf"
    '*' denotes best ucast next-hop
    '**' denotes best mcast next-hop
    '[x/y]' denotes [preference/metric]
    '%' in via output denotes VRF 
    
    10.31.0.0/30, ubest/mbest: 1/0, attached
        *via 10.31.0.1, Eth1/3.2, [0/0], 00:12:26, direct
    10.31.0.1/32, ubest/mbest: 1/0, attached
        *via 10.31.0.1, Eth1/3.2, [0/0], 00:12:26, local
    172.16.1.1/32, ubest/mbest: 2/0, attached
        *via 172.16.1.1, Lo0, [0/0], 00:12:29, local, tag 12345
        *via 172.16.1.1, Lo0, [0/0], 00:12:29, direct, tag 12345
    192.168.11.0/24, ubest/mbest: 1/0
        *via 10.31.0.2, [20/0], 00:12:21, bgp-65333, external, tag 65111
    192.168.12.0/24, ubest/mbest: 1/0
        *via 10.31.0.2, [20/0], 00:12:21, bgp-65333, external, tag 65111

Step 6 - Ext-Rtr: Logout


exit