Site1-L1
NDFC - Verify

Verify your Site1-L1 leaf switch.

Step 1 - Login to Site1-L1

Login to your Site1-L1 switch using the copy command below and paste into your VSCode Terminal. When prompted, the password is cisco.123 .

If prompted to accept the RSA key fingerprint like below, type or copy yes then input the password above.

    The authenticity of host '10.3.3.13 (10.3.3.13)' can't be established.
    RSA key fingerprint is SHA256:xneE+2XnZozaXwC/FgeYMRKJ4UhZV4iZD6QCD1u7gi8.
    Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
    Warning: Permanently added '10.3.3.13' (RSA) to the list of known hosts.
    User Access Verification
    Password: 

Step 2 - Site1-L1: Show Run Interfaces


show run interface ethernet 1/1-6 ; show run interface loopback0-1

Output:

    !Command: show running-config interface Ethernet1/1-6
    !No configuration change since last restart
    !Time: Wed Feb  1 15:10:11 2023

    version 9.3(10) Bios:version

    interface Ethernet1/1
    description connected-to-Site1-S1-Ethernet1/1
    no switchport
    mtu 9216
    ip address 10.1.0.5/31
    ip ospf network point-to-point
    ip router ospf UNDERLAY area 0.0.0.0
    ip pim sparse-mode
    no shutdown

    interface Ethernet1/2
    description connected-to-Site1-S2-Ethernet1/1
    no switchport
    mtu 9216
    ip address 10.1.0.3/31
    ip ospf network point-to-point
    ip router ospf UNDERLAY area 0.0.0.0
    ip pim sparse-mode
    no shutdown

    interface Ethernet1/3
    description "PO 500 (vpc-peer-link) member Site1-L1-Ethernet1/3 to Site1-L2-Ethernet1/3"
    switchport mode trunk
    channel-group 500 mode active

    interface Ethernet1/4
    description "PO 500 (vpc-peer-link) member Site1-L1-Ethernet1/4 to Site1-L2-Ethernet1/4"
    switchport mode trunk
    channel-group 500 mode active

    interface Ethernet1/5
    switchport access vlan 2300
    spanning-tree port type edge
    spanning-tree bpduguard enable
    mtu 9216

    interface Ethernet1/6
    switchport mode trunk
    switchport trunk allowed vlan none
    mtu 9216
    channel-group 1 mode active


    !Command: show running-config interface loopback0-1
    !No configuration change since last restart
    !Time: Wed Feb  1 15:10:11 2023

    version 9.3(10) Bios:version

    interface loopback0
    description Routing loopback interface
    ip address 10.11.0.1/32
    ip router ospf UNDERLAY area 0.0.0.0
    ip pim sparse-mode

    interface loopback1
    description VTEP loopback interface
    ip address 10.111.0.1/32
    ip address 10.111.0.2/32 secondary
    ip router ospf UNDERLAY area 0.0.0.0
    ip pim sparse-mode

Step 3 - Site1-L1: Show IP Interface Brief


show ip interface brief vrf all

Output:

    IP Interface Status for VRF "default"(1)
    Interface            IP Address      Interface Status
    Vlan3600             10.1.0.0        protocol-up/link-up/admin-up       
    Lo0                  10.11.0.1       protocol-up/link-up/admin-up       
    Lo1                  10.111.0.1      protocol-up/link-up/admin-up       
    Eth1/1               10.1.0.5        protocol-up/link-up/admin-up       
    Eth1/2               10.1.0.3        protocol-up/link-up/admin-up       
    
    IP Interface Status for VRF "management"(2)
    Interface            IP Address      Interface Status
    mgmt0                10.15.10.13     protocol-up/link-up/admin-up       
    
    IP Interface Status for VRF "bluevrf"(3)
    Interface            IP Address      Interface Status
    Vlan2000             forward-enabled protocol-up/link-up/admin-up       
    Vlan2300             192.168.11.1    protocol-up/link-up/admin-up       
    Vlan2301             192.168.12.1    protocol-up/link-up/admin-up

Step 4 - Site1-L1: Show Run vPC


show run vpc

Output:

    !Command: show running-config vpc
    !No configuration change since last restart
    !Time: Wed Feb  1 15:22:57 2023

    version 9.3(10) Bios:version
    feature vpc

    vpc domain 1
    peer-switch
    peer-keepalive destination 10.15.10.14 source 10.15.10.13
    delay restore 150
    peer-gateway
    auto-recovery reload-delay 360
    ipv6 nd synchronize
    ip arp synchronize

    interface port-channel1
    vpc 1

    interface port-channel500
    vpc peer-link

Step 5 - Site1-L1: Show vPC


show vpc

Output:

    Legend:
        (*) - local vPC is down, forwarding via vPC peer-link

    vPC domain id                     : 1   
    Peer status                       : peer adjacency formed ok      
    vPC keep-alive status             : peer is alive                 
    Configuration consistency status  : success 
    Per-vlan consistency status       : success                       
    Type-2 consistency status         : success 
    vPC role                          : primary                       
    Number of vPCs configured         : 1   
    Peer Gateway                      : Enabled
    Dual-active excluded VLANs        : -
    Graceful Consistency Check        : Enabled
    Auto-recovery status              : Enabled, timer is off.(timeout = 360s)
    Delay-restore status              : Timer is off.(timeout = 150s)
    Delay-restore SVI status          : Timer is off.(timeout = 10s)
    Operational Layer3 Peer-router    : Disabled
    Virtual-peerlink mode             : Disabled

    vPC Peer-link status
    ---------------------------------------------------------------------
    id    Port   Status Active vlans    
    --    ----   ------ -------------------------------------------------
    1     Po500  up     1,2000,2300-2301,3600                                                

    vPC status
    ----------------------------------------------------------------------------
    Id    Port          Status Consistency Reason                Active vlans
    --    ------------  ------ ----------- ------                ---------------
    1     Po1           down*  success     success               -                           
                                                                                

    Please check "show vpc consistency-parameters vpc " for the 
    consistency reason of down vpc and for type-2 consistency reasons for 
    any vpc.

Step 6 - Site1-L1: Show vPC


show run interface port-channel1

Output:

    !Command: show running-config interface port-channel1
    !No configuration change since last restart
    !Time: Wed Feb  1 15:23:19 2023

    version 9.3(10) Bios:version

    interface port-channel1
    switchport mode trunk
    switchport trunk allowed vlan none
    spanning-tree port type edge trunk
    spanning-tree bpduguard enable
    mtu 9216
    vpc 1

Step 7 - Site1-L1: Verify Underlay OSPF Running Config


show run ospf

Output:

    !Command: show running-config ospf
    !No configuration change since last restart
    !Time: Wed Feb  1 15:11:10 2023

    version 9.3(10) Bios:version
    feature ospf

    router ospf UNDERLAY
    router-id 10.11.0.1

    interface Vlan3600
    ip ospf network point-to-point
    ip router ospf UNDERLAY area 0.0.0.0

    interface loopback0
    ip router ospf UNDERLAY area 0.0.0.0

    interface loopback1
    ip router ospf UNDERLAY area 0.0.0.0

    interface Ethernet1/1
    ip ospf network point-to-point
    ip router ospf UNDERLAY area 0.0.0.0

    interface Ethernet1/2
    ip ospf network point-to-point
    ip router ospf UNDERLAY area 0.0.0.0

Step 8 - Site1-L1: Verify Underlay OSPF Neighbors


show ip ospf neighbors

Output:

    OSPF Process ID UNDERLAY VRF default
    Total number of neighbors: 3
    Neighbor ID     Pri State            Up Time  Address         Interface
    10.11.0.3         1 FULL/ -          00:40:09 10.1.0.4        Eth1/1 
    10.11.0.4         1 FULL/ -          00:40:03 10.1.0.2        Eth1/2 
    10.11.0.2         1 FULL/ -          00:39:58 10.1.0.1        Vlan3600

Step 9 - Site1-L1: Verify Underlay PIM Running Config


show run pim

Output:

    !Command: show running-config pim
    !No configuration change since last restart
    !Time: Wed Feb  1 15:11:17 2023

    version 9.3(10) Bios:version
    feature pim

    ip pim rp-address 10.251.251.1 group-list 239.1.1.0/25
    ip pim ssm range 232.0.0.0/8


    interface Vlan3600
    ip pim sparse-mode

    interface loopback0
    ip pim sparse-mode

    interface loopback1
    ip pim sparse-mode

    interface Ethernet1/1
    ip pim sparse-mode

    interface Ethernet1/2
    ip pim sparse-mode

Step 10 - Site1-L1: Verify Underlay PIM Neighbors


show ip pim neighbor

Output:

    PIM Neighbor Status for VRF "default"
    Neighbor        Interface            Uptime    Expires   DR       Bidir-  BFD    ECMP Redirect
                                                            Priority Capable State     Capable
    10.1.0.4        Ethernet1/1          00:40:23  00:01:16  1        yes     n/a     no
    10.1.0.2        Ethernet1/2          00:40:22  00:01:20  1        yes     n/a     no
    10.1.0.1        Vlan3600             00:40:13  00:01:27  1        yes     n/a     no

Step 11 - Site1-L1: Verify BGP Running Config


show run bgp

Output:

    !Command: show running-config bgp
    !No configuration change since last restart
    !Time: Wed Feb  1 15:11:24 2023

    version 9.3(10) Bios:version
    feature bgp

    router bgp 65111
    router-id 10.11.0.1
    neighbor 10.11.0.3
        remote-as 65111
        update-source loopback0
        address-family l2vpn evpn
        send-community
        send-community extended
    neighbor 10.11.0.4
        remote-as 65111
        update-source loopback0
        address-family l2vpn evpn
        send-community
        send-community extended
    vrf bluevrf
        address-family ipv4 unicast
        advertise l2vpn evpn
        redistribute direct route-map fabric-rmap-redist-subnet
        maximum-paths ibgp 2
        address-family ipv6 unicast
        advertise l2vpn evpn
        redistribute direct route-map fabric-rmap-redist-subnet
        maximum-paths ibgp 2
    evpn
    vni 30000 l2
        rd auto
        route-target import auto
        route-target export auto
    vni 30001 l2
        rd auto
        route-target import auto
        route-target export auto
    vrf context bluevrf
    rd auto
    address-family ipv4 unicast
        route-target both auto
        route-target both auto evpn
    address-family ipv6 unicast
        route-target both auto
        route-target both auto evpn

Step 12 - Site1-L1: BGP EVPN Neighbors


show bgp l2vpn evpn summary

Output:

    BGP summary information for VRF default, address family L2VPN EVPN
    BGP router identifier 10.11.0.1, local AS number 65111
    BGP table version is 11, L2VPN EVPN config peers 2, capable peers 2
    4 network entries and 4 paths using 976 bytes of memory
    BGP attribute entries [3/516], BGP AS path entries [0/0]
    BGP community entries [0/0], BGP clusterlist entries [0/0]
    
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    10.11.0.3       4 65111      56      48       11    0    0 00:40:16 0         
    10.11.0.4       4 65111      56      48       11    0    0 00:40:12 0 

Step 13 - Site1-L1: Verify NVE VTEP Interface Running Config


show run interface nve1

Output:

    !Command: show running-config interface nve1
    !No configuration change since last restart
    !Time: Wed Feb  1 15:11:39 2023

    version 9.3(10) Bios:version

    interface nve1
    no shutdown
    host-reachability protocol bgp
    source-interface loopback1
    member vni 30000
        mcast-group 239.1.1.1
    member vni 30001
        mcast-group 239.1.1.1
    member vni 50000 associate-vrf 

Step 14 - Site1-L1: Verify NVE VTEP Interface State


show nve interface nve 1 detail

Output:

    Interface: nve1, State: Up, encapsulation: VXLAN
    VPC Capability: VPC-VIP-Only [notified]
    Local Router MAC: 5200.0017.1b08
    Host Learning Mode: Control-Plane
    Source-Interface: loopback1 (primary: 10.111.0.1, secondary: 10.111.0.2)
    Source Interface State: Up
    Virtual RMAC Advertisement: No
    NVE Flags: 
    Interface Handle: 0x49000001
    Source Interface hold-down-time: 180
    Source Interface hold-up-time: 30
    Remaining hold-down time: 0 seconds
    Virtual Router MAC: 0200.0a6f.0002
    Interface state: nve-intf-add-complete

Step 15 - Site1-L1: VXLAN VNIs


show nve vni

Output:

    Codes: CP - Control Plane        DP - Data Plane          
            UC - Unconfigured         SA - Suppress ARP        
            SU - Suppress Unknown Unicast 
            Xconn - Crossconnect      
            MS-IR - Multisite Ingress Replication
        
        Interface VNI      Multicast-group   State Mode Type [BD/VRF]      Flags
        --------- -------- ----------------- ----- ---- ------------------ -----
        nve1      30000    239.1.1.1         Up    CP   L2 [2300]               
        nve1      30001    239.1.1.1         Up    CP   L2 [2301]               
        nve1      50000    n/a               Up    CP   L3 [bluevrf]

Step 16 - Site1-L1: Anycast Gateways


show run interface vlan2000, vlan2300-2301

Output:

    !Command: show running-config interface Vlan2000, Vlan2300-2301
    !No configuration change since last restart
    !Time: Wed Feb  1 15:18:16 2023
    
    version 9.3(10) Bios:version
    
    interface Vlan2000
      description BlueVRF
      no shutdown
      mtu 9216
      vrf member bluevrf
      no ip redirects
      ip forward
      ipv6 address use-link-local-only
      no ipv6 redirects
    
    interface Vlan2300
      description BlueNet1
      no shutdown
      vrf member bluevrf
      no ip redirects
      ip address 192.168.11.1/24 tag 12345
      no ipv6 redirects
      fabric forwarding mode anycast-gateway
    
    interface Vlan2301
      description BlueNet2
      no shutdown
      vrf member bluevrf
      no ip redirects
      ip address 192.168.12.1/24 tag 12345
      no ipv6 redirects
      fabric forwarding mode anycast-gateway

Step 17 - Site1-L1: Logout


exit