Site1-S1
NDFC - Verify
  • Introduction
  • ND Basics
  • NDFC Basics
  • NDFC Site1 Fabric (Greenfield)
  • Verify Site1 Fabric
  • NDFC Site2 Fabric (Brownfield)
  • Verify Site2 Fabric
  • NDFC External L3
  • Verify ExtL3
  • NDFC ISN
  • NDFC Multisite
  • Verify MSD
  • Ansible NDFC

Through NDFC you have created and deployed your Site1 Greenfield VXLAN EVPN fabric and performed a level of verification by checking the deployment status that NDFC reports. Now, you're going to use your VSCode application's Terminal to connect to some devices in your Site1 fabric to issue show commands for verification of the configuration deployed by NDFC. Additionally, using the Linux servers connected to your Site1-L1 and Site1-L2, you will perform data plane verification by checking connectivity to your Anycast Gateway and checking inter-VXLAN routing between your two servers.

Verification will start with your Site1-S1 spine switch.

Step 1 - Login to Site1-S1

The first device you will verify is your Site1-S1 switch. Login to your Site1-S1 switch using the copy command below and paste into your VSCode Terminal. When prompted, the password is cisco.123 .

If prompted to accept the RSA key fingerprint like below, type or copy yes then input the password above.

    The authenticity of host '10.3.3.11 (10.3.3.11)' can't be established.
    RSA key fingerprint is SHA256:xneE+2XnZozaXwC/FgeYMRKJ4UhZV4iZD6QCD1u7gi8.
    Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
    Warning: Permanently added '10.3.3.11' (RSA) to the list of known hosts.
    User Access Verification
    Password: 

Step 2 - Site1-S1: Show Run Interfaces


show run interface ethernet 1/1-4 ; show run interface loopback0 ; show run interface loopback251

Output:

    !Command: show running-config interface Ethernet1/1-4
    !No configuration change since last restart
    !Time: Wed Feb  1 15:02:17 2023

    version 9.3(10) Bios:version

    interface Ethernet1/1
    description connected-to-Site1-L1-Ethernet1/1
    mtu 9216
    ip address 10.1.0.4/31
    ip ospf network point-to-point
    ip router ospf UNDERLAY area 0.0.0.0
    ip pim sparse-mode
    no shutdown

    interface Ethernet1/2
    description connected-to-Site1-L2-Ethernet1/1
    mtu 9216
    ip address 10.1.0.6/31
    ip ospf network point-to-point
    ip router ospf UNDERLAY area 0.0.0.0
    ip pim sparse-mode
    no shutdown

    interface Ethernet1/3
    description connected-to-Site1-BL1-Ethernet1/1
    mtu 9216
    ip address 10.1.0.10/31
    ip ospf network point-to-point
    ip router ospf UNDERLAY area 0.0.0.0
    ip pim sparse-mode
    no shutdown

    interface Ethernet1/4
    description connected-to-Site1-BGW1-Ethernet1/1
    mtu 9216
    ip address 10.1.0.14/31
    ip ospf network point-to-point
    ip router ospf UNDERLAY area 0.0.0.0
    ip pim sparse-mode
    no shutdown


    !Command: show running-config interface loopback0
    !No configuration change since last restart
    !Time: Wed Feb  1 15:02:17 2023

    version 9.3(10) Bios:version

    interface loopback0
    description Routing loopback interface
    ip address 10.11.0.3/32
    ip router ospf UNDERLAY area 0.0.0.0
    ip pim sparse-mode


    !Command: show running-config interface loopback251
    !No configuration change since last restart
    !Time: Wed Feb  1 15:02:17 2023

    version 9.3(10) Bios:version

    interface loopback251
    description RP loopback interface
    ip address 10.251.251.1/32
    ip router ospf UNDERLAY area 0.0.0.0
    ip pim sparse-mode

Step 3 - Site1-S1: Verify Underlay OSPF Running Config


show run ospf

Output:

    !Command: show running-config ospf
    !No configuration change since last restart
    !Time: Wed Feb  1 14:52:58 2023

    version 9.3(10) Bios:version
    feature ospf

    router ospf UNDERLAY
    router-id 10.11.0.3

    interface loopback0
    ip router ospf UNDERLAY area 0.0.0.0

    interface loopback251
    ip router ospf UNDERLAY area 0.0.0.0

    interface Ethernet1/1
    ip ospf network point-to-point
    ip router ospf UNDERLAY area 0.0.0.0

    interface Ethernet1/2
    ip ospf network point-to-point
    ip router ospf UNDERLAY area 0.0.0.0

    interface Ethernet1/3
    ip ospf network point-to-point
    ip router ospf UNDERLAY area 0.0.0.0

    interface Ethernet1/4
    ip ospf network point-to-point
    ip router ospf UNDERLAY area 0.0.0.0

Step 4 - Site1-S1: Verify Underlay OSPF Neighbors


show ip ospf neighbors

Output:

    OSPF Process ID UNDERLAY VRF default
    Total number of neighbors: 4
    Neighbor ID     Pri State            Up Time  Address         Interface
    10.11.0.1         1 FULL/ -          00:23:28 10.1.0.5        Eth1/1 
    10.11.0.2         1 FULL/ -          00:23:24 10.1.0.7        Eth1/2 
    10.11.0.5         1 FULL/ -          00:23:34 10.1.0.11       Eth1/3 
    10.11.0.6         1 FULL/ -          00:23:34 10.1.0.15       Eth1/4

Step 5 - Site1-S1: Verify Underlay PIM Running Config


show run pim

Output:

    !Command: show running-config pim
    !No configuration change since last restart
    !Time: Wed Feb  1 14:57:06 2023

    version 9.3(10) Bios:version
    feature pim

    ip pim rp-address 10.251.251.1 group-list 239.1.1.0/25
    ip pim ssm range 232.0.0.0/8
    ip pim anycast-rp 10.251.251.1 10.11.0.3
    ip pim anycast-rp 10.251.251.1 10.11.0.4


    interface loopback0
    ip pim sparse-mode

    interface loopback251
    ip pim sparse-mode

    interface Ethernet1/1
    ip pim sparse-mode

    interface Ethernet1/2
    ip pim sparse-mode

    interface Ethernet1/3
    ip pim sparse-mode

    interface Ethernet1/4
    ip pim sparse-mode

Step 6 - Site1-S1: Verify Underlay PIM Neighbors


show ip pim neighbor

Output:

    PIM Neighbor Status for VRF "default"
    Neighbor        Interface            Uptime    Expires   DR       Bidir-  BFD    ECMP Redirect
                                                             Priority Capable State     Capable
    10.1.0.5        Ethernet1/1          00:26:15  00:01:40  1        yes     n/a     no
    10.1.0.7        Ethernet1/2          00:26:12  00:01:39  1        yes     n/a     no
    10.1.0.11       Ethernet1/3          00:26:26  00:01:21  1        yes     n/a     no
    10.1.0.15       Ethernet1/4          00:26:26  00:01:30  1        yes     n/a     no

Step 7 - Site1-S1: Verify BGP Running Config


show run bgp

Output:

    !Command: show running-config bgp
    !No configuration change since last restart
    !Time: Wed Feb  1 14:59:16 2023

    version 9.3(10) Bios:version
    feature bgp

    router bgp 65111
    router-id 10.11.0.3
    neighbor 10.11.0.1
        remote-as 65111
        update-source loopback0
        address-family l2vpn evpn
        send-community
        send-community extended
        route-reflector-client
    neighbor 10.11.0.2
        remote-as 65111
        update-source loopback0
        address-family l2vpn evpn
        send-community
        send-community extended
        route-reflector-client
    neighbor 10.11.0.5
        remote-as 65111
        update-source loopback0
        address-family l2vpn evpn
        send-community
        send-community extended
        route-reflector-client
    neighbor 10.11.0.6
        remote-as 65111
        update-source loopback0
        address-family l2vpn evpn
        send-community
        send-community extended
        route-reflector-client

Step 8 - Site1-S1: BGP EVPN Neighbors


show bgp l2vpn evpn summary

Output:

    BGP summary information for VRF default, address family L2VPN EVPN
    BGP router identifier 10.11.0.3, local AS number 65111
    BGP table version is 22, L2VPN EVPN config peers 4, capable peers 4
    8 network entries and 8 paths using 1952 bytes of memory
    BGP attribute entries [4/688], BGP AS path entries [0/0]
    BGP community entries [0/0], BGP clusterlist entries [0/0]

    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    10.11.0.1       4 65111      42      37       22    0    0 00:28:24 4         
    10.11.0.2       4 65111      40      38       22    0    0 00:28:21 4         
    10.11.0.5       4 65111      34      34       22    0    0 00:28:23 0         
    10.11.0.6       4 65111      34      34       22    0    0 00:28:17 0 

Step 9 - Site1-S1: Logout


exit