Site2-L1
NDFC - Verify

Verify your Site2-L1 leaf switch.

Step 1 - Login to Site2-L1

Login to your Site2-L1 switch using the copy command below and paste into your VSCode Terminal. When prompted, the password is cisco.123 .

If prompted to accept the RSA key fingerprint like below, type or copy yes then input the password above.

    The authenticity of host '10.3.3.18 (10.3.3.18)' can't be established.
    RSA key fingerprint is SHA256:xneE+2XnZozaXwC/FgeYMRKJ4UhZV4iZD6QCD1u7gi8.
    Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
    Warning: Permanently added '10.3.3.18' (RSA) to the list of known hosts.
    User Access Verification
    Password: 

Step 2 - Site2-L1: Show Run Interfaces


show run interface ethernet 1/1-6 ; show run interface loopback0-1

Output:

    !Command: show running-config interface Ethernet1/1-6
    !No configuration change since last restart
    !Time: Wed Feb  1 16:36:02 2023
    
    version 9.3(10) Bios:version
    
    interface Ethernet1/1
      description connected-to-site2-s1-Ethernet1/1
      no switchport
      mtu 9216
      ip address 10.2.0.1/31
      ip ospf network point-to-point
      ip router ospf UNDERLAY area 0.0.0.0
      ip pim sparse-mode
      no shutdown
    
    interface Ethernet1/2
    
    interface Ethernet1/3
    
    interface Ethernet1/4
    
    interface Ethernet1/5
    
    interface Ethernet1/6
    
    
    !Command: show running-config interface loopback0-1
    !No configuration change since last restart
    !Time: Wed Feb  1 16:36:02 2023
    
    version 9.3(10) Bios:version
    
    interface loopback0
      description Routing loopback interface
      ip address 10.22.0.1/32
      ip router ospf UNDERLAY area 0.0.0.0
      ip pim sparse-mode
    
    interface loopback1
      description VTEP loopback interface
      ip address 10.222.0.1/32
      ip router ospf UNDERLAY area 0.0.0.0
      ip pim sparse-mode

Step 3 - Site2-L1: Verify Underlay OSPF Running Config


show run ospf

Output:

    !Command: show running-config ospf
    !No configuration change since last restart
    !Time: Wed Feb  1 16:36:33 2023
    
    version 9.3(10) Bios:version
    feature ospf
    
    router ospf UNDERLAY
      router-id 10.22.0.1
    
    interface loopback0
      ip router ospf UNDERLAY area 0.0.0.0
    
    interface loopback1
      ip router ospf UNDERLAY area 0.0.0.0
    
    interface Ethernet1/1
      ip ospf network point-to-point
      ip router ospf UNDERLAY area 0.0.0.0

Step 4 - Site2-L1: Verify Underlay OSPF Neighbors


show ip ospf neighbors

Output:

    OSPF Process ID UNDERLAY VRF default
    Total number of neighbors: 1
    Neighbor ID     Pri State            Up Time  Address         Interface
    10.22.0.4         1 FULL/ -          00:26:49 10.2.0.0        Eth1/1 

Step 5 - Site2-L1: Verify Underlay PIM Running Config


show run pim

Output:

    !Command: show running-config pim
    !No configuration change since last restart
    !Time: Wed Feb  1 16:37:12 2023
    
    version 9.3(10) Bios:version
    feature pim
    
    ip pim rp-address 10.252.252.1 group-list 239.1.1.0/25
    ip pim ssm range 232.0.0.0/8
    
    
    interface loopback0
      ip pim sparse-mode
    
    interface loopback1
      ip pim sparse-mode
    
    interface Ethernet1/1
      ip pim sparse-mode

Step 6 - Site2-L1: Verify Underlay PIM Neighbors


show ip pim neighbor

Output:

    PIM Neighbor Status for VRF "default"
    Neighbor        Interface            Uptime    Expires   DR       Bidir-  BFD    ECMP Redirect
                                                             Priority Capable State     Capable
    10.2.0.0        Ethernet1/1          00:27:27  00:01:44  1        yes     n/a     no

Step 7 - Site2-L1: Verify BGP Running Config


show run bgp

Output:

    !Command: show running-config bgp
    !No configuration change since last restart
    !Time: Wed Feb  1 16:38:06 2023

    version 9.3(10) Bios:version
    feature bgp

    router bgp 65222
    router-id 10.22.0.1
    neighbor 10.22.0.4
        remote-as 65222
        update-source loopback0
        address-family l2vpn evpn
        send-community
        send-community extended
    vrf RedVRF
        address-family ipv4 unicast
        advertise l2vpn evpn
        redistribute direct route-map fabric-rmap-redist-subnet
        maximum-paths ibgp 2
        address-family ipv6 unicast
        advertise l2vpn evpn
        redistribute direct route-map fabric-rmap-redist-subnet
        maximum-paths ibgp 2
    evpn
    vni 49000 l2
        rd auto
        route-target import auto
        route-target export auto
    vrf context RedVRF
    rd auto
    address-family ipv4 unicast
        route-target both auto
        route-target both auto evpn
    address-family ipv6 unicast
        route-target both auto
        route-target both auto evpn

Step 8 - Site2-L1: BGP EVPN Neighbors


show bgp l2vpn evpn summary

Output:

    BGP summary information for VRF default, address family L2VPN EVPN
    BGP router identifier 10.22.0.1, local AS number 65222
    BGP table version is 3, L2VPN EVPN config peers 1, capable peers 1
    0 network entries and 0 paths using 0 bytes of memory
    BGP attribute entries [0/0], BGP AS path entries [0/0]
    BGP community entries [0/0], BGP clusterlist entries [0/0]
    
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    10.22.0.4       4 65222      33      33        3    0    0 00:27:58 0 

Step 9 - Site2-L1: Verify NVE VTEP Interface Running Config


show run interface nve1

Output:

    !Command: show running-config interface nve1
    !No configuration change since last restart
    !Time: Wed Feb  1 16:38:55 2023
    
    version 9.3(10) Bios:version
    
    interface nve1
      no shutdown
      host-reachability protocol bgp
      source-interface loopback1
      member vni 49000
        mcast-group 239.1.1.1
      member vni 59000 associate-vrf 

Step 10 - Site1-L1: Verify NVE VTEP Interface State


show nve interface nve 1 detail

Output:

    Interface: nve1, State: Up, encapsulation: VXLAN
    VPC Capability: VPC-VIP-Only [not-notified]
    Local Router MAC: 5200.0038.1b08
    Host Learning Mode: Control-Plane
    Source-Interface: loopback1 (primary: 10.222.0.1, secondary: 0.0.0.0)
    Source Interface State: Up
    Virtual RMAC Advertisement: No
    NVE Flags: 
    Interface Handle: 0x49000001
    Source Interface hold-down-time: 180
    Source Interface hold-up-time: 30
    Remaining hold-down time: 0 seconds
    Virtual Router MAC: N/A
    Interface state: nve-intf-add-complete

Step 11 - Site2-L1: VXLAN VNIs


show nve vni

Output:

    Codes: CP - Control Plane        DP - Data Plane          
            UC - Unconfigured         SA - Suppress ARP        
            SU - Suppress Unknown Unicast 
            Xconn - Crossconnect      
            MS-IR - Multisite Ingress Replication

        Interface VNI      Multicast-group   State Mode Type [BD/VRF]      Flags
        --------- -------- ----------------- ----- ---- ------------------ -----
        nve1      49000    239.1.1.1         Up    CP   L2 [2999]               
        nve1      59000    n/a               Up    CP   L3 [RedVRF]

Step 12 - Site2-L1: Anycast Gateways


show run interface vlan2299, vlan2999

Output:

    !Command: show running-config interface Vlan2299, Vlan2999
    !No configuration change since last restart
    !Time: Wed Feb  1 16:39:49 2023

    version 9.3(10) Bios:version

    interface Vlan2299
    description RedVRF
    no shutdown
    mtu 9216
    vrf member RedVRF
    no ip redirects
    ip forward
    ipv6 address use-link-local-only
    no ipv6 redirects

    interface Vlan2999
    description RedNet1
    no shutdown
    mtu 9216
    vrf member RedVRF
    ip address 192.168.21.1/24
    fabric forwarding mode anycast-gateway

Step 13 - Site2-L1: Logout


exit