Site2-S1
NDFC - Verify
  • Introduction
  • ND Basics
  • NDFC Basics
  • NDFC Site1 Fabric (Greenfield)
  • Verify Site1 Fabric
  • NDFC Site2 Fabric (Brownfield)
  • Verify Site2 Fabric
  • NDFC External L3
  • Verify ExtL3
  • NDFC ISN
  • NDFC Multisite
  • Verify MSD
  • Ansible NDFC

Step 1 - Login to Site2-S1

The first device you will verify is your Site2-S1 switch. Login to your Site2-S1 switch using the copy command below and paste into your VSCode Terminal. When prompted, the password is cisco.123 .

If prompted to accept the RSA key fingerprint like below, type or copy yes then input the password above.

    The authenticity of host '10.3.3.17 (10.3.3.17)' can't be established.
    RSA key fingerprint is SHA256:xneE+2XnZozaXwC/FgeYMRKJ4UhZV4iZD6QCD1u7gi8.
    Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
    Warning: Permanently added '10.3.3.17' (RSA) to the list of known hosts.
    User Access Verification
    Password: 

Step 2 - Site2-S1: Show Run Interfaces


show run interface ethernet 1/1-4 ; show run interface loopback0 ; show run interface loopback252

Output:

    !Command: show running-config interface Ethernet1/1-4
    !No configuration change since last restart
    !Time: Wed Feb  1 15:54:02 2023
    
    version 9.3(10) Bios:version
    
    interface Ethernet1/1
      description connected-to-site2-l1-Ethernet1/1
      mtu 9216
      ip address 10.2.0.0/31
      ip ospf network point-to-point
      ip router ospf UNDERLAY area 0.0.0.0
      ip pim sparse-mode
      no shutdown
    
    interface Ethernet1/2
      no shutdown
    
    interface Ethernet1/3
      no shutdown
    
    interface Ethernet1/4
      description connected-to-site2-bgw1-Ethernet1/1
      mtu 9216
      ip address 10.2.0.2/31
      ip ospf network point-to-point
      ip router ospf UNDERLAY area 0.0.0.0
      ip pim sparse-mode
      no shutdown
    
    
    !Command: show running-config interface loopback0
    !No configuration change since last restart
    !Time: Wed Feb  1 15:54:02 2023
    
    version 9.3(10) Bios:version
    
    interface loopback0
      description Routing loopback interface
      ip address 10.22.0.4/32
      ip router ospf UNDERLAY area 0.0.0.0
      ip pim sparse-mode
    
    
    !Command: show running-config interface loopback252
    !No configuration change since last restart
    !Time: Wed Feb  1 15:54:02 2023
    
    version 9.3(10) Bios:version
    
    interface loopback252
      description RP loopback interface
      ip address 10.252.252.1/32
      ip router ospf UNDERLAY area 0.0.0.0
      ip pim sparse-mode

Step 3 - Site2-S1: Verify Underlay OSPF Running Config


show run ospf

Output:

    !Command: show running-config ospf
    !No configuration change since last restart
    !Time: Wed Feb  1 15:54:42 2023
    
    version 9.3(10) Bios:version
    feature ospf
    
    router ospf UNDERLAY
      router-id 10.22.0.4
    
    interface loopback0
      ip router ospf UNDERLAY area 0.0.0.0
    
    interface loopback252
      ip router ospf UNDERLAY area 0.0.0.0
    
    interface Ethernet1/1
      ip ospf network point-to-point
      ip router ospf UNDERLAY area 0.0.0.0
    
    interface Ethernet1/4
      ip ospf network point-to-point
      ip router ospf UNDERLAY area 0.0.0.0

Step 4 - Site2-S1: Verify Underlay OSPF Neighbors


show ip ospf neighbors

Output:

    OSPF Process ID UNDERLAY VRF default
    Total number of neighbors: 2
    Neighbor ID     Pri State            Up Time  Address         Interface
    10.22.0.1         1 FULL/ -          01:50:56 10.2.0.1        Eth1/1 
    10.22.0.6         1 FULL/ -          01:51:43 10.2.0.3        Eth1/4 

Step 5 - Site2-S1: Verify Underlay PIM Running Config


show run pim

Output:

    !Command: show running-config pim
    !No configuration change since last restart
    !Time: Wed Feb  1 15:54:51 2023
    
    version 9.3(10) Bios:version
    feature pim
    
    ip pim rp-address 10.252.252.1 group-list 239.1.1.0/25
    ip pim ssm range 232.0.0.0/8
    ip pim anycast-rp 10.252.252.1 10.22.0.4
    
    
    interface loopback0
      ip pim sparse-mode
    
    interface loopback252
      ip pim sparse-mode
    
    interface Ethernet1/1
      ip pim sparse-mode
    
    interface Ethernet1/4
      ip pim sparse-mode

Step 6 - Site2-S1: Verify Underlay PIM Neighbors


show ip pim neighbor

Output:

    PIM Neighbor Status for VRF "default"
    Neighbor        Interface            Uptime    Expires   DR       Bidir-  BFD    ECMP Redirect
                                                            Priority Capable State     Capable
    10.2.0.1        Ethernet1/1          01:51:13  00:01:23  1        yes     n/a     no
    10.2.0.3        Ethernet1/4          01:52:03  00:01:38  1        yes     n/a     no

Step 7 - Site2-S1: Verify BGP Running Config


show run bgp

Output:

    !Command: show running-config bgp
    !No configuration change since last restart
    !Time: Wed Feb  1 15:56:17 2023
    
    version 9.3(10) Bios:version
    feature bgp
    
    router bgp 65222
      router-id 10.22.0.4
      neighbor 10.22.0.1
        remote-as 65222
        update-source loopback0
        address-family l2vpn evpn
          send-community
          send-community extended
          route-reflector-client
      neighbor 10.22.0.6
        remote-as 65222
        update-source loopback0
        address-family l2vpn evpn
          send-community
          send-community extended
          route-reflector-client

Step 8 - Site2-S1: BGP EVPN Neighbors


show bgp l2vpn evpn summary

Output:

    BGP summary information for VRF default, address family L2VPN EVPN
    BGP router identifier 10.22.0.4, local AS number 65222
    BGP table version is 4, L2VPN EVPN config peers 2, capable peers 2
    0 network entries and 0 paths using 0 bytes of memory
    BGP attribute entries [0/0], BGP AS path entries [0/0]
    BGP community entries [0/0], BGP clusterlist entries [0/0]

    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    10.22.0.1       4 65222     118     118        4    0    0 01:52:22 0         
    10.22.0.6       4 65222     119     119        4    0    0 01:53:02 0 

Step 9 - Site2-S1: Logout


exit